v1.5.15rc3 Bug Reports and Comments

DOWNLOAD THE LATEST FIRMWARE HERE
User avatar
Stephen
Employee
Employee
 
Posts: 963
Joined: Sun Dec 24, 2017 8:56 pm
Has thanked: 77 times
Been thanked: 169 times

v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 12:47 pm

Latest WS Release Candidate: v1.5.15rc3
Click HERE to download firmware v1.5.15rc3 - Released 11/7/2023

FIXED/CHANGED
- Fixed SNMP init error (causing memory leaks) - rc1
- Fixed kernel page-cache failure - rc1
- Fixed watchdog memory leak - rc1
- Fixed leak in net-snmp causing "No MemShared" error in logs - rc2
- Fixed SFP port link flapping on config change - rc3

ENHANCEMENTS

KNOWN ISSUES
- WEB UI issues when not at 100% Zoom on browser especially on VLAN TAB
- Some language templates need help

Released 11/7/2023

User avatar
Stephen
Employee
Employee
 
Posts: 963
Joined: Sun Dec 24, 2017 8:56 pm
Has thanked: 77 times
Been thanked: 169 times

Re: v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 1:40 pm

Just so everyone is aware of what is happening.

Right now we're trying to stabilize a few long running issues in the WS firmware. But if this release candidate addresses most of the major concern's the next topic of interest is optimizing WS3 to address issue's people have been reporting about config changes failing/locking up the switch.

User avatar
mayheart
Experienced Member
 
Posts: 155
Joined: Thu Jan 15, 2015 1:42 pm
Location: Canada
Has thanked: 41 times
Been thanked: 37 times

Re: v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 2:01 pm

Amazing. I will test this on a few sites that we have with fiber and see if it fixes it.

The only other outstanding bug that I've seen with the WS2 line is if I have two links on a site with one port in shutdown. If I shut down one port and bring up the other, all the other side sees is untagged traffic.

I have to disable one port, enable the other and reboot the switch for traffic to pass again.

Thank you very much!

User avatar
mayheart
Experienced Member
 
Posts: 155
Joined: Thu Jan 15, 2015 1:42 pm
Location: Canada
Has thanked: 41 times
Been thanked: 37 times

Re: v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 2:41 pm

I can confirm rc3 fixes the SFP flapping issues. I applied it to one device I usually get locked out of. VLANs were added/removed without problems.

User avatar
sirhc
Employee
Employee
 
Posts: 7346
Joined: Tue Apr 08, 2014 3:48 pm
Location: Lancaster, PA
Has thanked: 1597 times
Been thanked: 1317 times

Re: v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 2:45 pm

mayheart wrote:
The only other outstanding bug that I've seen with the WS2 line is if I have two links on a site with one port in shutdown. If I shut down one port and bring up the other, all the other side sees is untagged traffic.

I have to disable one port, enable the other and reboot the switch for traffic to pass again.



That is odd!!!

How do you have the port disabled. POE turned off or port disabled with POE on. I assume both ports are in the same VLAN?

Can you post up screen grabs of the following TABs: STATUS - VLAN - PORTS - RSTP

**** Remember to upload pics please use the Upload attachment link below the three BLUE buttons below this box on this page.
Support is handled on the Forums not in Emails and PMs.
Before you ask a question use the Search function to see it has been answered before.
To do an Advanced Search click the magnifying glass in the Search Box.
To upload pictures click the Upload attachment link below the BLUE SUBMIT BUTTON.

User avatar
mayheart
Experienced Member
 
Posts: 155
Joined: Thu Jan 15, 2015 1:42 pm
Location: Canada
Has thanked: 41 times
Been thanked: 37 times

Re: v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 3:18 pm

I have one of the ethernet ports shutdown but both are powered up.

In this case, Port 1 is the AF5X HD and port 7 is the AF60 XR.

Both ports are enabled on the far end, same settings. spanning-tree disabled and the same vlans allowed.

Enabling or disabling spanning-tree on both sides make no difference.

This used to work at some point but this was many firmware revisions ago.

Soon as I enable port 7 and disable port 1, all traffic is sent to the far end without any vlan tagging. I confirmed this on a packet capture. If I reboot the near side switch, everything is fine.
Attachments
nbay ports.jpg
nb vlan.jpg
nbay status.jpg
nbay spanning tree.jpg

jpmoller
Member
 
Posts: 32
Joined: Thu Oct 03, 2019 3:24 pm
Has thanked: 7 times
Been thanked: 5 times

Re: v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 3:25 pm

We have the same issue. If there are two ports that may cause a loop in the network and you enable one and shutdown the other on the same config change, the switch just locks up. We usually have to reboot the switch. Enabling/disabling STP has no effect. Luckily we only experience this in our provisioning lab.

In our case, we fully disable the port (no PoE).

User avatar
Stephen
Employee
Employee
 
Posts: 963
Joined: Sun Dec 24, 2017 8:56 pm
Has thanked: 77 times
Been thanked: 169 times

Re: v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 3:42 pm

If possible to get, switch logs of these events would be very helpful.

User avatar
mayheart
Experienced Member
 
Posts: 155
Joined: Thu Jan 15, 2015 1:42 pm
Location: Canada
Has thanked: 41 times
Been thanked: 37 times

Re: v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 3:59 pm

Nothing interesting in the logs.

Nov 7 14:10:57 UI: Configuration changed by root (::ffff:x)
Nov 7 14:10:57 UI: Port 1 Enable: changed from 'Enabled' to 'Disabled'
Nov 7 14:11:23 UI: Configuration changed by root (::ffff:x)
Nov 7 14:11:23 UI: Port 7 Enable: changed from 'Disabled' to 'Enabled'

Far side is now unreachable. Rebooting the switch brought up the traffic back again on port 7.

User avatar
Stephen
Employee
Employee
 
Posts: 963
Joined: Sun Dec 24, 2017 8:56 pm
Has thanked: 77 times
Been thanked: 169 times

Re: v1.5.15rc3 Bug Reports and Comments

Tue Nov 07, 2023 4:18 pm

Good enough, just for confirmation of series of events. Thanks

Next
Return to Hardware and software issues

Who is online

Users browsing this forum: No registered users and 9 guests