v1.5.9rcX Bug Reports and Comments

DOWNLOAD THE LATEST FIRMWARE HERE
User avatar
Stephen
Employee
Employee
 
Posts: 952
Joined: Sun Dec 24, 2017 8:56 pm
Has thanked: 77 times
Been thanked: 163 times

v1.5.9rcX Bug Reports and Comments

Mon Apr 12, 2021 4:07 pm

Click HERE to download firmware v1.5.9rcX - Released 4/12/2021
Click HERE to go to the Download Latest Firmware thread

v1.5.9rcX wrote:
IF A SWITCH ARRIVED WITH 1.5.5 PRELOADED PLEASE CHECK THIS THREAD

FIXED/CHANGED

ENHANCEMENTS
- Dropbear version upgraded from v0.53 to v2020.81 - RC1

KNOWN ISSUES
- WEB UI issues when not at 100% Zoom on browser especially on VLAN TAB
- Some language templates need help - please private message Stephen Copeland to help

Released 4/12/2021

User avatar
david.sovereen@mercury.net
Member
 
Posts: 33
Joined: Tue Sep 29, 2015 6:17 pm
Location: Midland, MI
Has thanked: 0 time
Been thanked: 1 time

Re: v1.5.9rcX Bug Reports and Comments

Tue Apr 13, 2021 6:25 am

It does not appear this MSTP issue was resolved yet, viewtopic.php?f=17&t=6787&p=33984#p33984, and the TLS browser issue still needs to be fixed.
Thanks,

Dave

User avatar
Stephen
Employee
Employee
 
Posts: 952
Joined: Sun Dec 24, 2017 8:56 pm
Has thanked: 77 times
Been thanked: 163 times

Re: v1.5.9rcX Bug Reports and Comments

Tue Apr 13, 2021 11:16 am

That is correct, Dropbear is the first step to upgrading several components that needed to be improved for security and performance including TLS.

It's true that MSTP is still open, but also note that all the improvements that have been made up to this point are included beginning in firmware v1.5.8.
The next series of steps I'm taking with it is just to improve the CLI commands for MSTP.
You should still be able to use it with the same degree of success that JustJoe has reported towards the end of that thread.

User avatar
Omniflux
Experienced Member
 
Posts: 109
Joined: Tue Feb 24, 2015 3:04 pm
Has thanked: 5 times
Been thanked: 28 times

Re: v1.5.9rcX Bug Reports and Comments

Fri Jul 16, 2021 5:38 pm

Feature request: Ability to exclude specific ports from announcing LLDP, CDP, etc.

User avatar
Stephen
Employee
Employee
 
Posts: 952
Joined: Sun Dec 24, 2017 8:56 pm
Has thanked: 77 times
Been thanked: 163 times

Re: v1.5.9rcX Bug Reports and Comments

Sat Jul 17, 2021 1:06 am

Noted OmniFlux, interesting idea.

bipbaep
Member
 
Posts: 19
Joined: Fri Jan 19, 2018 4:46 pm
Has thanked: 0 time
Been thanked: 2 times

Re: v1.5.9rcX Bug Reports and Comments

Tue Sep 07, 2021 7:28 am

Development for 1.gen Netonix switches has stopped? Nothing has happened since April.

User avatar
Stephen
Employee
Employee
 
Posts: 952
Joined: Sun Dec 24, 2017 8:56 pm
Has thanked: 77 times
Been thanked: 163 times

Re: v1.5.9rcX Bug Reports and Comments

Tue Sep 07, 2021 11:59 am

No it hasn't stopped, development's with the newer model had taken up all of our time however. I will be making a new release for the first gen switches soon. Right now my goal for them is to complete the upgrade on PHP and TLS, both of these however require some tooling change's which is also a lengthy process unfortunately. But work is still being done.

Flo
Member
 
Posts: 7
Joined: Sat Jan 09, 2021 10:41 pm
Has thanked: 0 time
Been thanked: 0 time

Re: v1.5.9rcX Bug Reports and Comments

Sun Oct 03, 2021 9:00 pm

Stephen wrote:No it hasn't stopped, development's with the newer model had taken up all of our time however. I will be making a new release for the first gen switches soon. Right now my goal for them is to complete the upgrade on PHP and TLS, both of these however require some tooling change's which is also a lengthy process unfortunately. But work is still being done.


Thanks for the update, Stephen.

ste93v
Member
 
Posts: 1
Joined: Tue Jan 18, 2022 10:46 am
Has thanked: 1 time
Been thanked: 0 time

Re: v1.5.9rcX Bug Reports and Comments

Tue Jan 18, 2022 11:28 am

We have recently come across the "TLS Cipher mismatch" error as well on our WS-12-250-AC switches using 1.5.9rcX when logging into them using Chrome version 98 and FireFox version 96. It seems to be involved with the switches using a deprecated version of SSL/TLS, but I understand that you are working on a fix as mentioned in a previous post. I attached a screenshot below from FireFox showing the "SSL_ERROR_UNSUPPORTED_VERSION" error.


Our temporary workaround is to change the "security.tls.version.enable-deprecated" setting to "true" on FireFox from the about:config page, but we cannot seem to find one for Chrome or Edge in any of its Internet settings, so this may eventually restrict remote access to our switches soon if these browsers do not allow older verisons of TLS. Is there an update on when this will be fixed?


Image

Return to Hardware and software issues

Who is online

Users browsing this forum: No registered users and 14 guests